注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

Oh! I see you!

Hi! ppmm~~

 
 
 

日志

 
 

Apache加载php模块提示错误Cannot load php5apache2_2.dll into server  

2016-11-22 21:09:52|  分类: Web |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

本文链接:http://oicu.cc.blog.163.com/blog/static/123039471201610229952552/


Apache 2.2.x 要以 handler 方式加载 php 模块,

php 官网 http://windows.php.net/downloads/releases/archives/ 里只有 php 5.2-5.4 的 Thread Safe 版本才带 php5apache2_2.dll,之后都是 php5apache2_4.dll(给 Apache 2.4.x 用)。不要下载名字带 nts 的 NoneThread Safe 版本。

 

之后无论怎么配置 Apache 的 httpd.conf 文件都提示错误:
Cannot load C:/php/php5apache2_2.dll into server

 

经过版本测试,发现:
1、其实 php5apache2_2.dll 相对绝对路径并不是大问题。
2、根据编译版本,安装对应的VC运行库。
3、最重要的一点谨记!x64 的 Apache 无法使用 x86 的 php 啊!

  评论这张
 
阅读(3509)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017